
 

Appendix 2: Worked example using GPS 
This appendix will talk the reader through how to use a GPS, get data out of the unit and 
use that data in the expedition GIS. The specific example used is a simple image 
rectification process.  This chapter will describe all the principles behind using GPS data 
and show how quickly it can be used to create an expedition map. To understand all the 
terms and processes in this appendix the user will have to read and understand the basic 
GPS chapter (Chapter 6) and the Photogrammetry and rectification chapter (Chapter 9).  

Using GPS to Rectify Images 
When collecting GPS points for rectification they must be taken as accurately as possible. 
This is done by locating a visible object in an image and determining the co-ordinate for 
that object either from a previous map, a rectified image or from ground control in the 
field. Taking these rectification points in the field is very difficult. An example of how 
difficult it is to locate point features on raster imagery is shown below. There is a clear 
difficulty in mapping the co-ordinates for the SE corner of the Royal Albert Memorial for 
ASTER (left) and even in an aerial photograph (right). Locating an exact pixel in the 
ASTER data to match a GPS co-ordinate is difficult even though the pixels for the statue 
are very different from the surrounding park. This example is substantially easier than the 
type of exercise expeditions will encounter in the field. 

 

 

 

 

 

 

 

 

 

 

 

Selecting Control Points. Difficulty in accurately mapping pixels for different data sets.  

The pixels labelled 1, 2, 3 and 4 in the ASTER enlargement show the problem of signal 
returns in areas of mixed ground types. Pixel 4 is clearly grass and pixel 1 appears to be 
urban and therefore part of the statue. It is therefore tempting to place the rectification 
mark at the edge of pixel 1 and pixel 3. Pixel 1 is not, however, as bright as some of the 
other pixels in the image above and therefore may be part of the path not the statue. The 
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aerial photograph clearly shows that the statue is not the only urban object in the area and 
the returns might be those of the pathway so the actual point may be further back. Pixels 2 
and 3 are even more difficult to interpret because their returns are definitely a mix of urban 
and grass. The edge of the statue might be somewhere in the middle of pixels 2 and 3 or 
back to the NW of pixel 1. Even on this simplest of exercises there is already a 2 pixel 
margin of error which in ASTER is at least 30 m.  

The Bogda Shan expedition discussed in Section 17.1 relied heavily on field rectified 
imagery. This was because maps better than 1:500,000 were considered sensitive and not 
made readily available to the team. Reading information off a map of 1:500,000 scale gives 
an error of 500 m for every millimetre of error. Lines and points plotted on this map may 
be plotted with an error of more than 2 mm making all the information less accurate than 1 
km. The Corona data was rectified by identifying common features on both the scanned 
imagery and the Landsat ETM+ panchromatic image. Even though the images were taken 
at a comparable time of the year, the different sun angle, differences in the terrain due to 
the temporal differences in the data, made the task very time consuming and inaccurate.  

Image to image rectification can be very difficult and some example screen grabs of 
rectifying a Corona image from a Landsat pan band is shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Example of Corona image (left) and Landsat pan band (right) showing three boulders used for 
rectification. Even with precise boulders and outcrops this exercise is difficult. 

The greater the difference in image formats the more difficult this exercise becomes. A 
common data source for expeditions will be aerial photography. Aerial photography has a 
much greater spatial resolution than satellite data and can be more difficult to rectify. 
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Because of these differences in the Corona and Landsat imagery, identifying features was 
difficult and no confidence could be given in anything other than a 6x6, 36-pixel grid. This 
introduced large errors, as shown in the table below. 

Errors generated from GPS rectification. 

Error Type Degree of Error Real World Error 

Landsat Geometric Error ~ ± 1 pixel (TM) ~50 m total (± 25 m) 

Point Identification ~ ± 3 pixels (Pan) ~90 m total (± 45 m) 

Error Propagation Unknown (~±1 pixel Pan) ~30 m Total (± 15 m) 

 

A much better method would have been to quickly use a GPS in the field to rectify the 
data. Once an expedition has collected GPS points they will need to be accessed to process 
out the data. To get the data out of the GPS needs some form of communication between 
the device and the expedition PC. 

Using HyperTerminal to Check a GPS signal 
When using a GPS and a PC together you first need to connect your GPS to a computer’s 
serial port. Most manufacturers have a proprietary cable connector so make sure you obtain 
the correct one. It is often a good idea to keep GPS units the same for all members, so that 
if one cable is lost or fails it can be substituted with an identical one.  

When physically connected a piece of software will be needed to bridge between the unit 
and the PC. This software is very rarely supplied with either the GPS or the cable. 
HyperTerminal is Microsoft’s software for communicating with connected devices. 
Though not very useful for expedition work, it is an excellent place to start and a good 
method for checking a GPS is working and that you understand GPS data. It can be used to 
test your settings and make sure everything is working before connecting to more in-depth 
software. Check HyperTerminal is installed: it should be located under Programmes ⇒ 
Accessories ⇒ Communications. If it is not present, it can be loaded by going to Control 
Panel ⇒ Add Remove Programmes ⇒ Windows Settings.  

When installed and located, open HyperTerminal and create a new connection. These 
instructions assume you are using a standard RS-232 connection but they can easily be 
adapted for either Bluetooth or USB connections. HyperTerminal must be told which port 
the GPS is connected to. Commonly this would be COM 1. Set the software to listen on 
Com port 1 unless instructed to do otherwise (a modem could be using COM 1 and the 
GPS may be assigned COM 2). A Bluetooth connection might be using a virtual port on 
COM 16, a USB – Serial adaptor commonly uses either COM 4 or 6. Set the Com port 
settings to the NMEA standard. Baud Rate 4800, Data Bits 8, No Parity, 1 stop bit as 
shown below. The GPS will then start sending the data to the screen. To log this to a text 
file select Transfer ⇒ Send to text file. 
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GPS NMEA settings. 

Baud Rate 4800 bits per second 

Bits 8 bit  

Parity None 

Stop Bits 1 

Flow Control Hardware Controlled 

This should demonstrate if the GPS is working and you should see a text stream like the 
following. 

$GPGGA,172704,5126.7759,N,00020.6673,W,1,05,1.3,13.8,M,47.4,M,,*67 

It is common if one of the settings is wrong, to see a string of random characters, usually 
using symbols. This suggests that the baud rate has been set incorrectly. Bear in mind that 
some GPS units do not broadcast a standard NMEA string and some Bluetooth devices 
commonly broadcast at 38400 bits. This will allow you to test all possibilities and see the 
actual data before using a more automated solution. 

Using GPS software to Download Data 
A better method than streaming the data into HyperTerminal is to use a dedicated piece of 
software to extract stored data from the memory of a GPS. The advantage of this approach 
is that the GPS can be used separately from the PC for a sustained period before coming 
back to have its data downloaded. The other advantage of dedicate software is that it can 
overcome problems with projections. The X and Y data in the GPS is always stored in 
WGS84, so if the GPS is required to process an image into any other format, the software 
will have to reconvert the data back to the display information. There are many packages 
on the market that can do this and some GIS packages have built in scripts to handle data 
downloads.  

A good product for converting co-ordinates and for accessing the GPS memory is GPS 
Utility sometimes referred to as GPSU. GPS Utility can be downloaded free from 
www.gpsu.co.uk. To use the full product requires a registered licence. On registration (£25 
GBP), the programme can be used for downloading large files of data. The programme is 
predominantly configured for downloading stored GPS waypoint, trackpoints and routes. It 
is not designed for real-time access to NMEA data or for pseudo range extraction. 

Using GPS Utility to download data 
GPS Utility’s strong points are its ability to interface with many models of GPS and to 
correct/reproject co-ordinates. It can also be used to generate ArcView and MapInfo files 
from the GPS data. The three steps in using GPSU to download data from GPS are: 

Step 1:  Tell the Software about the GPS type you are using 
Step 2:  Define datum and projection 
Step 3:  Connect to the GPS 
 

http://www.gpsu.co.uk/
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Step 1: the first step is to tell the software about the receiver being used. Go to the menu 
item GPS ⇒ Setup and set the parameters as shown below. 

  

It is also worth checking Options ⇒ Field Properties to ensure that any altitude data is 
being downloaded correctly and that stored symbols can be output to GPS Utility. It is 
important to be aware what altitude data is stored in both waypoints and trackpoints by the 
expedition GPS receivers. 

Step 2: define the co-ordinate system and datum, using File ⇒ New (or CTRL-N). First set 
the co-ordinate system being used (see Chapter 2), then select the appropriate datum to its 
right. These settings do not affect the format in which data is downloaded; rather, it 
determines the format that GPSU uses for displaying and saving data. 

 

Select the type of GPS you 
are using GPS Type normally 
either Garmin or Magellan 

Com Port (usually 1) - this is 
the name of the 9-pin serial 
port on the computer 

The lower half of the screen 
can be left as the defaults. 
More details on the NMEA 
strings can be found in 
Chapter 11. 

These menus allow you to 
change the co-ordinate system 
and datum, shown right 
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The datum is selected from a pre-defined list.  If a required datum is not already held in 
GPSU, then a custom datum can be defined (in terms of angular and distance offsets from 
the WGS84 datum). A far greater selection is available than listed in this dialog: use ‘Add’ 
to include further datums. In this example, ‘Arc 1960’ has been added; it is used in much 
mapping of East and Central Africa.  

Step 3: connect to the GPS using GPS ⇒ Connect. This will automatically find the GPS 
model attached to the PC and display its details down in the status bar at the bottom of the 
screen. Next go to GPS ⇒ Download all. This gives the opportunity to select all the GPS 
point types that are required for the study (i.e. tracks waypoints etc.). Click OK and the 
programme downloads all the data. To save the data for import into a GIS click File ⇒ 
Save. There are many file format options here, making GPSU a useful adjunct to most GIS 
programmes. 

Three commonly used formats are: 

Shapefile: these can be read directly into ArcView (versions 3.x and 8.x), as well as many 
other GIS programmes. There is the option of saving Shapefiles as points, or in the case of 
track-logs, as lines. Shapefiles comprise several separate files: GPSU typically saves three 
(.dbf, .shp, .shx). The .dbf file can also be read by database and spreadsheet applications 
such as Excel, Access and FoxPro. 

MapInfo Interchange File (.MIF): for import into MapInfo. Waypoints are saved as 
individual points, while tracklogs are saved as lines. 

Text file: this can be useful for several reasons. Proprietary file formats change and may be 
error-prone, so it is always advisable to make a plain-text copy of all downloaded data. It 
also allows greatest flexibility if you are unsure which format to use: it can later be read 
back into GPSU for re-export in a particular format. Finally, plain text files can readily be 
edited in any text editor, such as Notepad or Wordpad, explained in the next section. 
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Editing GPS data in text format 
Though there are ways of bringing data directly into a GIS, converting it to a text file first 
can be useful because it allows initial checks and editing to be carried out and un-needed 
data to be weeded out. Because we need the data for Ground Control Points (GCPs) we 
require the data in a text format, so we will look at methods for exporting the data. The 
figure above shows how a text file saved by GPSU is structured. The header specifies the 
co-ordinate system and datum, followed by the sections containing waypoint data, a track 
summary (which can usually be ignored), and track point data. 

Header information 

Section 1 
Waypoint Data 

Section 3 
Track Data 

Section 2 
Track Summary 
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Before data can be read by a GIS or database it requires cleaning and formatting. If an 
application such as HyperTerminal or GPSU has been used to export a text file, then the 
text will have to be converted to its correct data type before being analysed (see Chapter 4 
for more details on data types). The best way to achieve this formatting is by using a 
parsing filter. Microsoft Excel has a good parsing filter built in as standard and is a 
reasonably common piece of software. This section will concentrate on how Excel can be 
used as part of the GISci software suite. 

 Microsoft Excel’s parsing filter. 

Copy the waypoints from the text file and paste them into Excel (remembering to delete 
any spurious header data). The data will be pasted into Excel as text, usually all together in 
one column. To divide the data into the correct columns and restore the appropriate data 
types to each field, use the parsing filter ‘Text to Columns’: highlight the column that the 
data has been exported to (usually column A) and choose Data > Text to Columns. Select 
‘Fixed Width’, then ‘Next’. Check the new columns look right (a line should separate each 
column, and no data should have been chopped from one column into another), then click 
‘Finish’. The data will now be in columns for the import. Instead of pasting, you can also 
open the text file using ‘File ⇒ Open’, then follow the ‘Import’ dialog, similar to ‘Convert 
Text’. 

Save as a Dbase IV file and then repeat for the track data. Clean out any data that looks 
spurious. Garmin GPS units often have strings of test data in the downloads; these will 
need to be deleted before loading the information into the GIS. When the data is formatted 
and cleaned, it can be imported into the GIS. The GPS data can also be used to rectify raw 
satellite data. This process can be seen schematically over the page. 
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For many expeditions raw, high resolution data such as Corona may be ideal. Depending 
on how Corona data is imported into the computer, the imagery can have a spatial 
resolution of down to six feet. When in the PC the GPS can be used to make a map from 
the raw data. The four steps in this process are shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Visit USGS EROS Data centre to 
acquire data http://eros.usgs.gov/ 

21 micron scan 1200 dots per inch = 20730.2/1200 = 17.28 feet 

14 micron scan 1800 dots per inch = 20730.2/1800 = 11.52 feet 

7 micron scan 3600 dots per inch = 20730.2/1200 = 5.76 feet 

Corona data is in strips of film measuring approx 2 inches by 2 foot 
covering a swath on the ground of 8.6 miles by 117 miles. 

1 

2 Acquire negatives and have them scanned or select the 
scanning method straight from the USGS. Scan type affects 
the pixel size in the raster images. 

Scan types available from USGS and resultant pixel resolutions: 

3 Acquire ground control points using a GPS in the field or 
other data such as maps or rectified imagery.  

117 miles convert to feet = (5280*117) = 61,7760 feet 
61,7760 / 29 = 20730 ∴each inch on the negative = 20730 feet 

4 Rectify the data using the expedition PC. This can 
then be overlain with a grid to create a map.  

http://eros.usgs.gov/
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Rectifying Data using ER Mapper 
To demonstrate the power of accurate GPS co-ordinates this section will demonstrate the 
rectification of a Corona scene of Southern Spain. ER Mapper (described in Section 
14.4.2) has a good geocoding wizard that is very simple to follow. It might not be the best 
suited to expeditions but it should allow a good understanding of how GPS data can be 
used when extracted from the unit. The geocoding wizard has a series of tabs and this 
tutorial will work through each of the five steps in turn. This is a very rough and ready 
walk through for using GPS data with your imagery and the team should understand the 
principles of rectification outlined in Chapter 9. 

 

 

 

 

 

 

 

 

 

  

 

On Tab 1 select the input file. ER Mapper will not detect this from the open window and 
you must specify it separately. Then you must select the geocoding type. The critical 
choices are either polynomial or orthorectify. These options are displayed below. 

 

 

 

 

 

 

 

 

The most common choice when using GPS data is Polynomial. When this option is 
selected the wizard guides moves onto Tab 2.  

Polynomial rectification is 
used for individually 
recorded points such as 
GPS data or points read 
off a map; whereas 
orthorectification requires 
a 3D model. 

The Geocoding Wizard 
can be found under the 
Process menu item. 
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On Tab 2 the polynomial order is selected. A general equation for polynomial order is 
GCP+1*GCP+2 / 2. The reader is advised to read Chapter 9 to understand the different 
options available when rectifying data. This is only a brief walk-through of how one 
program handles the operations and the expedition needs to understand the concepts in 
detail so they can apply them across the board to any software they encounter. ER Mapper 
offers three degrees of transformation. A linear transformation requires 3 GCP, Quadratic 
requires 6, points and cubic requires 10 GCP. Select the transformation that matches the 
number of GCP recorded. Tab 3 determines the output co-ordinate types for the finished 
data. Though this might seem complicated at first, there are various options to help you. 
The projection defines the method of laying the 3D surface onto a 2D plane. The system 
defines how these co-ordinates are entered and the choices will be dictated by the maps or 
imagery the rectified data needs to be referenced against. In this case, a UTM projection 
for Spain is used. Tab 3 allows you to select the method for transferring your co-ordinates 
from your corrected data to your raw data. Select the Geocoded image, vector or algorithm 
dialogue and in the bottom half of the screen click ‘change’. Then input the correct datum, 
projection and co-ordinate type. A co-ordinate space is defined by a datum, a projection 
and a system. The datum defines where the ellipsoid intersects the geoid. The projection 
defines the method of laying the 3D surface onto a 2D plane. The software delineates 
where and how these co-ordinates should be entered. Existing maps and imagery will 
largely dictate the choices made. In this case, a UTM projection for Spain is used. When an 
image is first brought into the system it has no co-ordinates and is described as being 
“RAW” data. 

 

 

 

 

 

 

 

The choice of a projection, datum etc. 
will largely be determined for the 
expedition by existing maps etc. A full 
discussion on how to select this data is 
given in Chapter 2. 

Tabs 2 and 3
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Once these decisions have been made the Ground Control Points can be added to the image 
and the GPS co-ordinates can be entered. GCPs can be added and manipulated at will. 
Each GCP will have an estimated RMS error. Try to keep these errors as low as possible 
but refer to Chapter 9 (especially Figure 9-18) to see the pitfalls when only relying on 
RMS. The error should preferably be around the error of your collected data, though this is 
not always possible. In this case, the GPS data has an error of around 10-20 m so the RMS 
errors should not be more than twice this level. 

 

 

 

 

 

 

 

 

 

The finished project should look something similar to the table below:   

 

 

 

 

 

 

 

 

 

 

 

 

The data can then be used with other datasets such as SRTM to give perspective views or 
used with other 2D datasets to give change images. 

 

 


